QLab 5GeneralWhat's New In QLab 5?

What's New In QLab 5?

This is a more or less fully inclusive list of the differences between QLab 5 and QLab 4. For changes made after the initial release of 5.0, check out the change log.

General

Stop, QLaborate, and Listen

QLab 5 allows multiple people on separate Macs to collaborate on a workspace, live and in realtime, on a local network.

Autosave

Autosave prevents accidental loss of work in the event of a crash or power outage. No guarantees are made against data loss due to user error, acts of God, or most hauntings.

I Am Not Throwing Away My Snapshot

As part of Autosave, QLab 5 optionally saves a snapshot of your workspace every time you save, allowing you to easily access earlier versions of your work.

Playlist Mode

Group cues have a new Playlist mode that allows you to create sequential playlists which advance automatically or manually with optional crossfading, shuffling, and looping.

Audition Improvements

The Audition Window has been replaced by a set of audition-related tools:

  • Each category of cue output (Audio, Video, MIDI, MTC Timecode, LTC Timecode, Network, and Light) can be individually set to audition to a specific output, the same output as usual, or no output.
  • Video output can also be set to audition to an audition window. Video stages (formerly called video surfaces) each get their own audition window.
  • Light cues audition to an “Audition” tab in the Light Dashboard.
  • Audition and Audition Preview actions let you audition individual cues and cue sequences without affecting the rest of the workspace.
  • Workspaces can be set to Always audition which turns every into an Audition and every Preview into an Audition Preview, in the style of QLab 4.
  • Cues in the midst of auditioning can be interrupted and restarted normally with a single or Preview command; no need to stop first, then restart.

Going Dark!

QLab 5 uses macOS Dark Mode so that dialogue boxes, title bars, and other window “chrome” look more consistent with the rest of QLab’s interface.

Cues A La Cart

Cue carts have received a variety of updates:

  • You can now manually set the grid size of a cart anywhere from 1 × 1 cells up to 10 × 10 cells.
  • Cart cues can now have pre-waits.
  • Cart cues display their duration and pre-wait, if applicable, when they are not playing.
  • Carts now have three display sizes, just like lists, which can be configured in the General → Display Size section of Workspace Settings.
  • Assorted improvements to aesthetics and legibility.

Conditional Coloration

Cue colors can be set to appear all the time, only before the cue has played, or only after the cue has played, making it easier for you to use color to mark cues as “unplayed” or “played.”

Reconnect With Old Friends

A new file search tool makes it easier to reconnect broken cues to their missing file targets, for example after moving a workspace to a new computer or reorganizing media while QLab is not running.

Drag-and-drop now less of a drag

Setting cues’ targets by drag and drop now works bi-directionally: you can drag the acting cue onto its target cue, or drag the target cue onto the acting cue. If both cues could potentially be targets of each other, the dragged cue is set as the target of the cue it’s dropped onto.

Related but separate, dragging cues onto Group cues now sets the Group cue as the target of the dragged cues, instead of potentially re-targeting all the child cues of that Group cue.

Right Click, Right Time

Right-clicking (or clicking with the control key held down) on cues in the cue list or on controls in the inspector now brings up a contextual menu which gives you quick access to relevant actions and extensive in-line help text with links to the relevant section of the QLab manual online.

Hammer Out Danger, Hammer Out Warning

The Warnings tab of the Workspace Status window has been comprehensively updated to give you much more and much better information about broken cues as well as non-breaking warnings such as workspace settings which are in need of attention.

Workspace Settings To Go

Workspace Settings can now be exported to a settings file, imported from a settings file, imported from other open workspaces, and drag-and-dropped between workspaces.

Sharper Fades

The “linear” fade curve type can now be edited, allowing sharp-cornered multi-step fade curves.

Relatively Absolute fading confidence

Fade cues in “absolute” mode will now override and clear out any previously applied changes made by Fade cues in “relative” mode.

Negative Load

Load cues as well as OSC and AppleScript commands that involve loading, can now use negative numbers to load backwards from the end time of their targets, just like the Load to Time tool.

Audio

Patch Upgrades

Audio patches are now called audio output patches, and they have been overhauled in QLab 5 with the following improvements:

  • QLab now supports an unlimited number of audio output patches in a workspace. Audio output patches can be reordered, copied and pasted within a workspace and between workspaces, drag-and-dropped into the Finder to create a settings document, and drag-and-dropped to copy them into the audio settings of other workspaces.
  • You can create multiple audio output patches with the same audio device, each with its own routing and audio effects.
  • The audio patch editor now supports undo and redo.
  • All cues that output audio now use the same set of audio output patches (no more special output patches for Mic cues.)
  • If an audio device is disconnected, QLab will still display the name of the disconnected device in the audio inspector, making it easier to work with “offline” audio devices.
  • Audio patches can now use the system output, which is the audio device selected in System Preferences → Sound → Output. This makes it easier for a workspace to be used in a context where QLab ought to use the same audio output as the rest of the Mac, even if that output changes.

Mic Cue Flexibility

Mic cues now use separate audio input patches to designate the device they use for input. This lets you use separate audio input and output devices easily, without requiring you to set up an aggregate audio device. Audio input patches can be reordered, copied and pasted within a workspace and between workspaces, drag-and-dropped into the Finder to create a settings document, and drag-and-dropped to copy them into the audio settings of other workspaces.

Zero-Count Slices

Slices in Audio cues (and Video cues) can be set to a play count of 0; zero-count slices are seamlessly skipped during playback.

Batch-edit Waveforms

You can now visually edit the start and end times of multiple selected cues by dragging the start time and end time handles in the Time & Loops tab of the inspector.

Better By a Meter

Audio effect meters now work in all contexts, not just on outputs.

Video

The Most Metal QLab

The video rendering engine has been completely rewritten using the Metal framework, Apple’s modern and fully up-to-date video system. Come for the performance improvements, stay for the longevity.

Will It Blend? Yes.

QLab 5 adds per-cue blend modes, allowing you to composite cues in nearly limitless combinations.

NDI

QLab natively supports NDI 5 for both video input and output. QLab also supports NDI audio input and output.

In-camera Audio

Camera cues contain an embedded Mic cue, allowing you to use live audio alongside live video.

QLab Can You See Me

QLab can display monitor windows for every video input and output so that you can keep tabs on all your visual elements live and in realtime.

Video Effect Upgrades

Video, Camera, and Text cues can now use multiple video effects simultaneously. The list of available video effects has grown, too, thanks to the shift to Metal, and the amount of processing power needed for video effects (especially blurs) has been nicely reduced.

Patch Upgrades

QLab now supports an unlimited number of video input patches in a workspace. Video input patches can be reordered, copied and pasted within a workspace and between workspaces, drag-and-dropped into the Finder to create a settings document, and drag-and-dropped to copy them into the video settings of other workspaces.

Zero-Count Slices

Slices in Video cues (and Audio cues) can be set to a play count of 0; zero-count slices are seamlessly skipped during playback.

The Mask of Syphon

Masks and video surface geometry now happen “upstream” of Syphon outputs, allowing you to send more elaborately crafted video feeds to Syphon-receiving clients.

Crop It Like It’s Hot

Video, Camera, and Text cues now have an integrated crop attribute for quick and easy trimming.

Lighting

The Audition Tab

The Light Dashboard’s new Audition tab lets you audition Light cues, letting you view level changes without actually changing the live levels being output to your lighting system.

More Lights

QLab 5 ships with instrument definitions for over 1400 different fixtures from 61 manufacturers, including fixtures from the following manufacturers new to QLab:

  • Acme
  • AO Lighting
  • ARRI
  • Astera
  • Ayrton
  • Barco
  • BeamZ
  • Big Dipper
  • Blizzard
  • Boomtone DJ
  • Chauvet DJ
  • Christie
  • CITC
  • City Theatrical
  • Coemar
  • Color Kinetics
  • Draco
  • Eurolite
  • Froggy’s Fog
  • Gantom
  • ibiza-light
  • Infinity
  • JB Lighting
  • Marq
  • Mega-Lite
  • Minute Une
  • PR Lighting
  • Prolights
  • Rayzr
  • Robert Juliat
  • Rockville
  • ShowPro
  • Showtec
  • Stairville
  • Strand
  • Ultratec
  • Yellow River

Cut/Copy/Paste

Light commands can now be cut, copied, and pasted when they are selected in slider mode in the Levels tab of the Light cue inspector.

MIDI, Networking, Scripting, and Show Control

Chase Timecode (Not Waterfalls)

Cues set to trigger from timecode can now start in the middle of the cue based on incoming timecode, rather than just at the beginning of the cue, and will skip ahead or back in response to timecode skipping ahead or back. Additionally, Lists and Carts set to receive timecode can optionally be set to pause or stop their timecode-triggered cues when incoming timecode stops, with optional freewheeling up to two seconds.

A More Powerful Network Cue

The Network cue has been substantially revamped and now includes support for directly controlling a number of OSC-controllable programs and devices with a minimum of fuss and complexity. The available modes for the Network cue in QLab 5.0 are:

  • OSC Message
  • Plain Text (ASCII strings)
  • Hex Codes (hexadecimal values)
  • QLab 5
  • Go Button 3
  • atemOSC
  • Audio Definition Model (ADM)
  • Borealis Vor
  • Chamsys MagicQ family
  • Creative Connors Spikemark 5
  • d&b Soundscape DS100 (which improves upon and replaces the QLab 4 Soundscape/DS100 feature)
  • Disguise D3
  • ETC ColorSource AV
  • ETC EOS family (Element, Ion, Eos, Geo, etc.)
  • Flux Spat Revolution
  • High End Hog 4
  • Innovate Audio panLab 2
  • L’Acoustics L-ISA
  • Meyer GALAXY (Normal mode and Spacemap mode)
  • MusicTribe Behringer X32 and Midas M32
  • Yamaha Rivage family (PM3, PM5, PM7, and PM10)
  • ZoomOSC

The Network cue also supports both TCP and UDP transport, as well as OSC 1.1 argument types true, false, impulse, and null.

When live fade preview is switched on, Network cues in 2D fade mode now transmit their message as you drag the control dot around. This should make it easier to experiment with 2D network fades.

Also, 2D fade curve editing has been improved.

Patch Upgrades

Network patches can be reordered, copied and pasted within a workspace and between workspaces, drag-and-dropped into the Finder to create a settings document, and drag-and-dropped to copy them into the Network settings of other workspaces.

QLab now supports an unlimited number of MIDI patches in a workspace. MIDI patches can be reordered, copied and pasted within a workspace and between workspaces, drag-and-dropped into the Finder to create a settings document, and drag-and-dropped to copy them into the MIDI settings of other workspaces.

MIDI cues, MIDI File cues, and Timecode cues using MTC now all use the same set of patches.

Port Authority

You can now customize the port numbers that workspaces use to receive OSC messages and plain text messages.

Passcode Improvements

Workspaces can have multiple OSC passcodes, each with their own set of access permissions.

Custom OSC remote control commands are now compatible with workspaces that use OSC passcodes.

QLab Remote

  • Multiple window support on iPad. This means you can connect to multiple workspaces (on multiple Macs, even) and view them side by side, or you can have multiple simultaneous views into the same workspace.
  • QLab Remote 5 does a better job of automatically recovering from a momentary disconnection.
  • QLab Remote 5 does a better job of reconnecting to the same Mac after an interruption, even when there are multiple copies of the same workspace open on the network.
  • The passcode entry screen is much improved.
  • Several bugs are fixed, notably a zoom scale issue when switching between carts and a light instrument check issue pertaining to use of non-ASCII characters.
  • When connecting to a QLab 5 workspace, QLab Remote supports encrypted network communication.
  • QLab Remote 5 requires iOS 15 or later and is compatible with QLab 3.0 or later.

Specific Changes From QLab 4

  • QLab 5 requires a Mac running macOS 11 (Big Sur) or later.
  • Group cues now default to timeline mode.
  • The overall audio level for cues and devices is now referred to as “main”, not “master.”
  • The lighting term “submaster” has been replaced by the term “subcontroller.”
  • Workspace Settings has moved from the Window menu to the File menu.
  • Jump to cue… has moved from the Tools menu to the View menu, and has been renamed Select cue…
  • The main audio level of Mic cues and Camera cues now defaults to -inf to help prevent audible accidents.
  • The OSC and AppleScript “pitch shift” commands have been replaced with “preserve pitch” commands to directly match the checkbox in the inspector which they control.
  • All OSC and AppleScript pertaining to video settings have been substantially revised, since video settings and the video engine have themselves been substantially revised. Many if not most Network cues and Script cues imported from QLab 4 which have anything to do with video will likely need to be revised.
  • Copying or importing Network cues from QLab 4 that communicate with the d&b DS100 and use background images will need to have their background images re-connected.
  • QLab 5 does not import QCart files. If you have a QCart file in need of updating, you can open it in QLab 4, save it as a QLab 4 workspace, and then open that workspace in QLab 5 and re-save it as a QLab 5 workspace.

Still have a question?

Our support team is always happy to help.

Business Hours
M-F 9am-7pm (ET)
Current time at our headquarters